TeslaMate Erfahrungs- und Datenthread

Edit: falscher post

Mein Bruder konnte mir heute helfen.
Ich hatte wie geschrieben dann nichts weiter getestet und vorsichtshalber alles ruhen lassen.

Problem war wohl ein (oder mehrere) Images die noch liefen und bei denen dann wohl auch das ganze stop,… nichts brachte. Möglicherweise habe ich versehentlich irgendwo eine Kopie erstellt die aber nicht direkt sichtbar war, keine Ahnung wie und ob…
Es ist jetzt soweit hoffentlich wieder „repariert“ und sowohl teslamate (auf 1.27.4) als auch TSC laufen wieder.

Danke euch für die ganzen Tipps.

(Das Auskommentieren hatte ich nicht getestet, da ich nicht noch mehr in der yml rumpfuschen wollte, die Namensänderung hatte ich ja scheinbar auch falsch verstanden.)

3 „Gefällt mir“

Kann dein Bruder mich zufällig über Teams supporten. Komme auch nicht weiter :pensive:

Denke da würden sich hier (noch) fähigere Leute finden. Er ist zwar Informatiker aber hat mit Docker und co normalerweise nichts am Hut

1 „Gefällt mir“

Hab die neueste Version installiert und bin mal auf die neue Battery Health Seite gegangen. Hätte ich das mal lieber nicht gemacht. Der Wagen wurde am 6.7. gebaut und hat nach 3500km noch 77,5 kWh Kapazität nach ganzen 7 Ladezyklen. Muss ich mir jetzt Sorgen machen oder ist die Auswertung einfach nicht wirklich genau?

Ich konnte mein Docker Image nicht mehr aktualisieren, da der Docker Desktop (Version 4.25.1 auf einem Mac Mini) einen seltsamen Syntaxfehler in der docker-compose.yml mit der traefik Integration (wie in Advanced installation with Traefik, Let's Encrypt & HTTP Basic Auth | TeslaMate beschrieben) angemeckert hat, sobald man „docker compose pull“ o.ä. in der Konsole versucht hat.
Aus den Labels der .yml Datei konnte er sich keinen Reim mehr machen.

Nach einigem Suchen im Netz habe ich dann folgende Änderung in der docker-compose.yml vorgenommen:
vorher:

   - "traefik.http.routers.teslamate-ws.tls"

nachher:>

   - "traefik.http.routers.teslamate-ws.tls=yes"

Danach liess sich das Image wieder mit

docker compose pull

aktualisieren. Der Container lief aber ganz normal, dummerweise lief auch der cronjob zum Backup anlegen ins leere, ohne dass ich das gemerkt hätte.

5 6 * * * cd $HOME/docker_images && /usr/local/bin/docker-compose exec -T database pg_dump -U teslamate teslamate > /Volumes/Daten/Datenbank/teslamate.sql

Das ist völlig normal. Mach dir da mal keine Sorgen. Außerdem ist das ja nur eine grobe Richtung der BatteryHealth.

Außerdem kommen die momentanen Witterungseinflüsse dem ganzen ja nicht zugute.

3 „Gefällt mir“

Die Werte sind mmn errechnet aus Verbrauch und Aufladung. Entspricht auch nicht immer den Werten die ich über ScanMyTesla ausgelesen habe.

Und selbst die Werte aus SMT sind vom BMS geschätzt und verändern sich je nach Ladeverhalten negativ und verändern sich erneut nach einer Kalibrierung unter Optimaltemperatur für den Akku :wink:

die Batteryhealth ist nicht wirklich nützlich.
zum Start letzte Woche zeigt er bei neu noch 60kWh an, jetzt 59, dafür wurde „now“ um einiges mehr. nette Spielerei und lustig anzusehen, aber wirklich ernst nehmen kannst die Daten nicht.

Hast du einen LFP Akku und ist dein Auto recht neu oder TeslaMate recht neu?

Durch DC Ladung sinkt die Health, wenn der Wagen mit >80% angesteckt ist dann macht er Balancing der Zellen und danach ist wieder mehr Nutzbar. Hat alles nichts mit TeslaMate zu tun und das Dashboard ist für nicht LFP nützlich, für LFP ist ein Update in Arbeit.

Die Degradation ist zu Beginn am größten, und verlöuft nicht linear… Gegenwirken kann man, indem man dem Wagen Zeit zum Balacing gibt und er dadurch wieder mehr Kapazität nutzen kann. Habe ich als Laternenparker die ersten 35.000 km nicht gemacht (aber fast nur AC Ladung), zuletzt immer mal wieder (nach viel DC Ladungen) und seitdem hat er sich etwas erholt.

Kannst du mir noch sagen, wie du das gemacht hast?

Nach meinem Verständnis verbessert sich aber nicht die tatsächliche Degradation der Zellen, sondern die Messwerte aus dem BMS werden genauer.

Richtig, die Zellen sind ja auch nicht mehr degradiert, nur das BMS hat schlechter geschätzt vorher.

1 „Gefällt mir“

Gibt es schon eine Planung bezüglich der Umstellung auf die neue Fleet-API? Spannend ist aus Anwendersicht ja vor allem, wie es mit der Registrierung und ggfs. Abrechnung (jeder selbst bei Tesla? Oder jemand für das Projekt und kriegt dann Geld von den Nutzern?) ablaufen soll.

Ich habe mich daran gemacht das bei Tesla auszufüllen - erstmal wollen sie nur Firmenregistrierungen, keine privaten, und dann landet man bei einem Haufen OAUTH- und Keyrequest- Schritten für die mir v.a. die tiefen Kenntnisse mit Curl fehlen. Das wäre schön wenn das ggfs. mit einem Guide oder mit ein paar Scripten erschlagbar würde.

ich hab zuletzt im September DC geladen. Gesamt 14.000km >80% AC Anteil (nur 2 Urlaubsfahrten DC reißen den Schnitt runter) - im Alltag 100% AC.
Aber ja - bei LFP kannst das wohl derzeit ziemlich knicken.

Mit >= 80% am AC Lader angesteckt lassen, sobald das Auto schläft, macht er balancing mit 1mV pro 24h oder so.
Dadurch wird nicht nur der BMS genauer, sondern er kann wieder das maximale Nutzen, was von der Degradation noch übrig ist. ISt aber alles hier off topic.

1 „Gefällt mir“

Für LFP haben wir schon neue Dashboards, sind im nächsten Release enthalten.

5 „Gefällt mir“

Kannst du mir dann bitte einen Gefallen tun und die Odometer-Werte als Spalte(n) bei Drives und Charges in die Übersicht aufnehmen? Bei Drives wären wohl Start und Ende sinnvoll, was aber dann zwei neue Spalten wären… :man_shrugging:
Auf jeden Fall hab ich die schon immer vermisst…

Danke! :+1: