MCU Problem / Emmc fail - Wer hier hat das Problem?

Technische Probleme und deren Lösung...

Re: MCU Problem / Emmc fail - Wer hier hat das Problem?

von Vagtler » 23. Feb 2020, 20:40

IBUZA hat geschrieben:
Teslanaut hat geschrieben:Ich habe durch Zufall einen, zumindest bei mir sicher reproduzierbaren, Weg gefunden, die MCU (1) zum sicheren Absturz mit langem, doppelten (!) auto-reset zu bringen: Eingabe von "it" in der Spotify-Suche genügt.

So was ähnliches wurde schon mit einem anderen Suchwort berichtet. War für mich nicht repoduzierbar. Kling eher wie ein Vorbote auf baldigen eMMC tot. [...]

Auch bei mir ist das Verhalten reproduzierbar.

Ob das ein Vorbote auf einen baldigen eMMC-Tod sein könnte oder ist es ein Software-Fehler? Konnte jemand mit einem ausgetauschten Chip das schonmal ausprobieren?
Benutzeravatar
 
Beiträge: 741
Registriert: 28. Dez 2016, 12:15
Wohnort: Köln
Land: Deutschland
Fahrzeug: Tesla Model S

Re: MCU Problem / Emmc fail - Wer hier hat das Problem?

von LuckyLuke » 23. Feb 2020, 22:08

FE433C7D-C431-428E-B603-4E3987BF49A0.jpeg
FE433C7D-C431-428E-B603-4E3987BF49A0.jpeg (21.75 KiB) 331-mal betrachtet


No problem finding “it”
Sorry for the bad photo, tried to post here from my phone, that was not so good idea :)

PS: For a real "Notfall" like black screen you can always contact me so I can see to schedule you in on short term. Can't promise anything but I will try to help and be flexible where possible.
Zuletzt geändert von LuckyLuke am 23. Feb 2020, 22:17, insgesamt 2-mal geändert.
Benutzeravatar
 
Beiträge: 43
Registriert: 20. Aug 2013, 15:56
Wohnort: Niederlande (Eindhoven)

Re: MCU Problem / Emmc fail - Wer hier hat das Problem?

von Vagtler » 23. Feb 2020, 22:13

Which software version?
Benutzeravatar
 
Beiträge: 741
Registriert: 28. Dez 2016, 12:15
Wohnort: Köln
Land: Deutschland
Fahrzeug: Tesla Model S

Re: MCU Problem / Emmc fail - Wer hier hat das Problem?

von LuckyLuke » 23. Feb 2020, 22:14

2020.4.1
Benutzeravatar
 
Beiträge: 43
Registriert: 20. Aug 2013, 15:56
Wohnort: Niederlande (Eindhoven)

Re: MCU Problem / Emmc fail - Wer hier hat das Problem?

von segwayi2 » 23. Feb 2020, 22:16

T3SLArati hat geschrieben:
segwayi2 hat geschrieben:Die gefixte Mcu hat den Beta Routenplaner Test leider nicht bestanden und sich genauso aufgehängt wie das Original. Und das obwohl sie gefühlt erheblich fixer ist in der Bedienung der normalen Funktionen. Wunder kann sie nicht vollbringen.
Ein weiterer Grund um irgendwann auf Mcu 2 umzusteigen


Was für eine hast du denn bekommen mit oder ohne LTE? Hast du eine Ersatzteil nummer?

Beta routenplaner test? OK den kenn ich noch nicht??


Was ich meinte war wenn man eine Route über mehrere SuC berechnen lässt steigt die MCU irgendwann aus.
Segwayi2
https://twitter.com/segway_i2
P85 03/14
295.000 km
71 kWh usable full pack
Vers.: 2020.8.1.1 fd1e27c66
Benutzeravatar
Trusted User
Trusted User
 
Beiträge: 8906
Registriert: 24. Aug 2013, 11:50
Wohnort: Düsseldorf
Land: Deutschland

Re: MCU Problem / Emmc fail - Wer hier hat das Problem?

von Vagtler » 23. Feb 2020, 22:19

LuckyLuke hat geschrieben:2020.4.1

Thanks. Since my CPO is „brand new“ I will talk to „my“ Service Center first.
Benutzeravatar
 
Beiträge: 741
Registriert: 28. Dez 2016, 12:15
Wohnort: Köln
Land: Deutschland
Fahrzeug: Tesla Model S

Re: MCU Problem / Emmc fail - Wer hier hat das Problem?

von Tilliboy » 24. Feb 2020, 08:45

Also ich würde gerne Mal wissen, was wirklich ein MMC Problem ist, die MCU hat ja schon immer komische Sachen gemacht wie manchmal nicht gestartet, eingefroren, sehr langsame Routenberechnung - also was deutet auf ein MMC Problem hin ? Finde das auch irgendwie schwach von Tesla ,- könnte man das nicht technisch auslesen, wie viel schreibvorgânge durchgeführt würden bzw. wie viel noch übrigbleibt - wäre schon interessant, ob das Teil noch wenige Wochen hält oder doch noch ein paar Jahre - es scheint ja auch sehr variabel zu sein bei den unterschiedlichen Nutzern.
Tesla Model S 70D
Mein Empfehlungslink: http://ts.la/till9938
 
Beiträge: 494
Registriert: 20. Jul 2015, 23:41
Land: Deutschland
Fahrzeug: Tesla Model S

Re: MCU Problem / Emmc fail - Wer hier hat das Problem?

von einstern » 24. Feb 2020, 08:58

Theoretisch müsste es jeden mit der Zeit ereilen.
Manche der zickigen Verhaltensweisen sind womöglich schon in der Vergangenheit auf das Konto des schleichenden eMMC Todes gegangen.
2014 PV 50 kWp
2015 S85D
2016 WB 22kW und Boden-PV
2019 WP 13kW Erdwärme (statt Heizöl)
-- Elektrisch - So läuft das hier !
Benutzeravatar
 
Beiträge: 5418
Registriert: 16. Okt 2014, 17:54
Wohnort: Korbach
Land: Deutschland
Fahrzeug: Tesla Model S

Re: MCU Problem / Emmc fail - Wer hier hat das Problem?

von IBUZA » 24. Feb 2020, 11:53

Dr. Schiwago hat geschrieben:Finde das auch irgendwie schwach von Tesla ,- könnte man das nicht technisch auslesen, wie viel schreibvorgânge durchgeführt würden bzw. wie viel noch übrigbleibt - wäre schon interessant, ob das Teil noch wenige Wochen hält oder doch noch ein paar Jahre - es scheint ja auch sehr variabel zu sein bei den unterschiedlichen Nutzern.

Aussagen von LuckyLuke dazu hier im Thread (Zusammenfassung auf Deutsch unten):
spa hat geschrieben:"On newer cars with Hynix H26M42002GMR or H26M42003GMR there is a possibility to see how much erase cycles the chip has done by accessing service/developer screens on the mcu, this can be done over ethernet if you have the matching hsd/fakra cable.
These Hynix chips are rated for 3000 cycles, so if your chip would report 2000 cycles done then the lifetime is already at 66%.
But having that information really doesn’t say much since these chips can last shorter (or longer) then the rated cycle life."
LuckyLuke hat geschrieben:3000 P/E cycles is actually the industry accepted rating for MLC.
Also the emmc-health.sh script which is on all Tesla firmwares since early 2019 mentions this cycle number:
Code: Alles auswählen
    if has_quirk "jedec5life" ; then
        # Estimate "A" is typically for SLC health
        life_est_a=$(read_ext_csd_slices 268)
        # Estimate "B" is typically for MLC health
        life_est_b=$(read_ext_csd_slices 269)
        pre_eol_info=$(read_ext_csd_slices 267)
    else
        if has_quirk "hynixhealth" ; then
            # simulate JEDEC 5 life time info using 3000 P/E cycle limit
            # SLC data doesn't seem valid in the field, so don't even try
            # to set life_est_a
            # For MLC, round to nearest percentage using erase cycle counts
            if [ "${AVG_BLK_ERASES}" != "" ] ; then
                life_est_b=$(printf "0x%02x" $((AVG_BLK_ERASES/300+1)))
            fi
        fi
    fi

Google it, and you will find it on many websites like:
https://www.datalight.com/blog/2013/07/23/what-is-industrial-grade-emmc/
http://www.ni.com/product-documentation/10126/en/


Zusammenfassung auf Deutsch:
Auf neueren Fahrzeugen/MCUs, die bestimmte Speicherchips haben kann man (=SeC oder"Hacker") die Löschzyklen auslesen. Die magische Grenze liegt bei einem Wert von 3000. Dieser wird auch in den Kommentaren in einem Script genannt, das Tesla in aktuellen Firmwareversionen benutzt.

Fazit: Magisch ist die Grenze weil es natürlich auch früher oder viel später zum Versagen des Speicherchips kommen kann. Bei älteren Speicherchips, die das Auslesen noch nicht unterstützen, hat man keinen Anhaltspunkt für den baldigen MCU tot, als komisches Verhalten selbiger. Vielleicht wäre es gut, wenn jemand einen neuen Thread dazu aufmacht und im ersten Post das Wissen sammelt (vermutete Anzeichen, Verhalten bei Ausfall, Einschränkungen durch MCU Ausfall, Wer kann helfen?).
Gebt Dränglern keine Chance! FAHRT RECHTS
 
Beiträge: 467
Registriert: 1. Okt 2017, 16:34
Land: Schweiz

Re: MCU Problem / Emmc fail - Wer hier hat das Problem?

von T3SLArati » 24. Feb 2020, 13:17

IBUZA hat geschrieben:

Fazit: Magisch ist die Grenze weil es natürlich auch früher oder viel später zum Versagen des Speicherchips kommen kann. Bei älteren Speicherchips, die das Auslesen noch nicht unterstützen, hat man keinen Anhaltspunkt für den baldigen MCU tot, als komisches Verhalten selbiger. Vielleicht wäre es gut, wenn jemand einen neuen Thread dazu aufmacht und im ersten Post das Wissen sammelt (vermutete Anzeichen, Verhalten bei Ausfall, Einschränkungen durch MCU Ausfall, Wer kann helfen?).


Das Problem ist das wenn so ein "speicherblock" beschädigt ist wird ein unbeschädigt genommen, mit der Zeit fragmentieren also die Daten, zudem kommt hinzu wenn der Chip voll ist können keine Daten, oder nur ein Teil beschrieben werden - weswegen es zu verschiedenen Ausfällen kommt.

Wenn man die Lebensdauer des Chips anschaut (die max möglichen schreib/löschzyklen - beschädigte Blöcke) die der Hersteller angibt, kann es schon zu eklatanten Ausfällen bei 50% erreichte Lebensdauer kommen. ZB. Hat der eine plötzlich keine Navikarten mehr - und oft kann man mit einem Factory reset oder löschen der Trips/Daten usw die MCU wieder ein bissl wiederbeleben. Andere merken selbst bei 80% nur leichte Ruckler... Pauschal sagen das passiert, dann ist mcu fast tot funktioniert nicht.

Welche "alten" Chips meint er? Soweit ich weiß können alle alten MCU (Tegra) ausgelesen werden im SEC
 
Beiträge: 230
Registriert: 15. Feb 2020, 16:21
Land: Oesterreich
Fahrzeug: anderes Auto

VorherigeNächste

Wer ist online?
Mitglieder in diesem Forum: Schleifer, U.R. und 13 Gäste