TeslaMate Erfahrungs- und Datenthread

Hab’s eben auch gesehen und oben korrigiert.

Weißt du denn, warum das set +H das die Lösung ist? Mir erschließt sich das erst mal nicht… :man_shrugging:

Ich hab diese uralte Erklärung gefunden und demnach müsste bash im Portainer scheinbar am ! im Befehl scheitern. Seltsam…

Leider weiß ich das auch nicht wirklich. Ich vermute einfach das es am Bash liegt.
Hatte den selben eintrag dazu gesehen und es einfach ausprobiert

1 „Gefällt mir“

Hi, ich hab meinen Raspi Pi4 von Buster auf Bookworm upgegraded. Nun läuft Teslamate & Co wieder im Docker, jedoch noch „jungfräulich“.

Kann mir jemand sagen wie ich meine alten Teslamate Daten wieder mit an Board nehme oder wo’s eine Anleitung für einen „Nicht-IT’ler“ gibt?

1 „Gefällt mir“

Danke, danke, danke - es scheint zu laufen! Mal sehen ob neue Daten dann auch sauber reinlaufen.

Ich De** hab täglich Backups gemacht, aber auf die Idee diese zu verwenden kam ich nicht. Portainer Volumes Sicherungen, … mit allem kläglich gescheitert :rofl:

1 „Gefällt mir“

Beim Teslamate unter Dashboards - Charges sieht man ja die einzelnen Ladeort aufgeführt. Bei mir in der Arbeit hab ich da mehrere Adressen, weil die Charger etwas um den Standort dort herum führen. Kann man die zusammenfügen und dann z.B. eine Übersicht generieren, wieviel man insgesamt dort geladen hat im Vergleich zu zuhause und Rest?

Du kannst einen Geofence dafür anlegen. Ggf. zwei, falls es mit einem Kreis nicht klappt, oder eben einen sehr großen Kreis mit allen Ladeorten.

Dazu bei einer Ladung auf den Ort tippen, den Geofence entsprechend vergrößern oder verschieben und ihn z.B. „Arbeit“ nennen. Wenn die allen gleich viel kosten, kannst du das da auch hinterlegen.

Alle Charger innerhalb des Geofence werden dann zusammengefasst.

2 „Gefällt mir“

Die fixe Truppe, die sich jetzt um TeslaMate kümmert, gibt eine 1.28.0/1 raus und sagt hier nix :wink:

Ich sag danke! :+1:

6 „Gefällt mir“

Leider scheint bei mir etwas kaputt gegangen zu sein durch das Update
Der Dashboards Button hat seit dem Update keine Funktion mehr, hat jemand eine Idee wie das gefixt werden kann?
grafik

1 „Gefällt mir“

Ist mir auch so aufgefallen. Du kannst links oben über das normale Menü gehen, um das passende Dashboard aufzurufen.

Das war dann wohl ich… Gibt bereits einen fix, denke mal neues Release bei dockerhub dann in kürze…

3 „Gefällt mir“

Gibt es schon Planungen wie mit der neuen Api und dem von Tesla gewollten Modell der Registrierung durch gewerbliche Partner umgegangen wird?

TeslaMate braucht diesbezüglich (momentan*) nichts planen. Die die Fleet API, die du ja sicher meinst, ist nicht die Ablösung der Owner API! Alles was TeslaMate benutzt/benötigt wird weiter von der Owner API bereitgestellt. Die Owner API ist (und bleibt?*) Dreh- und Angelpunkt der Tesla-App, und diese macht im Kern (stand heute) exakt das gleiche um Informationen über das Fahrzeug abzurufen.

(*) kann sich natürlich jederzeit und auch ganz plötzlich ändern, aber es gibt einfach keine Anhaltspunkte dafür.

Das stimmt aber ich habe auch eigene Board die ich darüber aufgerufen habe.

Der Fix scheint ja wie spongyhat geschrieben hat schon auf dem weg zu sein.
Generell einmal ein danke an alle die vorher aber auch jetzt an dem Projekt mitgearbeitet habt! Echt ein klasse tool!

1 „Gefällt mir“

Wo nimmst Du diese Differenzierung her?

Tesla redet von einer REST-API, Du von einer Owner-Api. Die Owner-API ist technisch eine REST-Api, und ich finde im Netz keine Dokumentation einer anderen bestehenden REST-API als der hier verwendeten.

Wenn meine Vermutung zutrifft, werden wir das bald merken weil laut Tesla die derzeit ausgelieferten Fahrzeuge nicht mehr auf die alte API reagieren.

Bitte zeige mir einen Beleg, dass die REST-API die Tesla ablöst nicht die Owner-API ist.

Es steht einfach nirgendwo etwas von einer Abschaltung oder Änderung das nicht einen klaren Bezug oder eine Eingrenzung auf commands, command endpoints, command protocol, command authentication hat.

Der am einfachsten zu missverstehende Satz „Owner API will stop working as vehicles begin requiring end-to-end command authentication.“ aus https://github.com/teslamotors/vehicle-command/blob/main/README.md steht trotzdem in einem Projekt das vorne, hinten, oben und unten so gut wie ausschließlich mit commands zu tun hat, und wie man die nun eben signiert verpackt. TeslaMate hat mit commands nichts zu tun.

Gemeint ist ist hier „Owner API commands will stop working…“

Persönliche Spekulation und Interpretation. Ich freue mich wenn Du Recht hast, deine Prognose wird aber weder von diesem Text noch von irgendetwas das ich gesehen habe gestützt.

Gerne!

Wir habe ein großes Update bei Grafana durchgeführt, externe Plugins durch pures Grafana ersetzt. Hier sind wir über einen Bug in Grafana gestolpert, den wir aber umgehen können, fix ist bereits vorhanden, Tests laufen noch.
Für die Aufzeichnung usw. haben wir 321 Test-Cases, die für jeden commit automatisiert getestet werden. UI Test sind nicht automatisiert. Neuerdings bauen wir jedoch für jeden PR ein eigenes Docker Image, laden es auf ghcr hoch und können damit jedes neue Feature einzeln manuell testen, sodass wir über diesen Grafana Bug nicht mehr stolpern sollten.

6 „Gefällt mir“


Ich habe 1.28.1. Es fehlt die Status Icon oder?