Impressum / Datenschutz Forumsregeln
TFF FORUM TFF E.V. SUPERCHARGE-ME
TFF Forum

Smartphone lock/unlock nicht zuverlässig

Nachdem ich nun einige Tage damit herumexperimentiert habe, scheint mir, als wenn das nicht so funktioniert wie es soll.

Das mag mit meiner speziellen Konstellation oder meinem Smartphone zu tun haben, ich versuche hier mal zu dokumentieren,
was es (nicht) sein kann.

Folgende Tests getan:
-wenn es zufällig mal aufgeht geht es dann nicht automatisch zu
-wenn es mal automatisch verschließt, geht es beim nächsten Mal nicht automatisch auf
-wenn ich wie empfohlen den Flugmodus ein/aus Wechsel mache, geht es danach
-wenn ich mit allen möglichen BT-Tools Scans starte, BT sichtbar/unsichtbar, BT ein/aus BT scanning mache: bringt alles nichts!
-bereits 2mal war die Funktion „beim Verlassen verriegeln“ von selbst wieder deaktiviert !!!
-rebooten der MCU, no effect
(…)

Auffällig ist, das BT auf dem Smartphone problemlos funktioniert - d.h. zu dem Zeitpunkt wo das M3 es nicht schafft mit dem Ding zu reden, funktionieren alle anderen BT Dinge problemlos (die BT beacons im Fahrzeug werden immer sofort gelistet, ich kann mit anderen BT Geräten kommunizieren usw.)

Ich schließe daraus - messerscharf - der Fehler muß in der Tesla-App liegen, die es irgendwie nicht schafft, korrekt mit dem Fahrzeug zu kommunizieren.

Irgendwas spezielles passiert beim Wechsel des Flugmodus, nur was?

Edit:
Seit die Software im Fahrzeug nur noch einen der 4 BT-Token verwendet (und offenbar auf das triangulieren verzichtet) funktioniert es mit dem gleichen Smartphone (ohne Android-update) 100% perfekt.
Wenn es mal nicht geht, liegt es schlicht daran, das ich BT auf dem Phone versehentlich deaktiviert habe.

Hast Du ein iPhone oder ein Android?
Denn generell funktioniert der „Handyschlüssel“ mit Apple problemlos, wohingegen bei Android es sehr unterschiedlich ist.

Bei mir klappt es mit Android nur zu 100% wenn ich das Display einschalte - entsperren ist nicht notwendig. Daher vermute ich dass es mit dem Strom sparen zu tun hat auch wenn ich die App nach meinem Verständnis ausgenommen habe.

Nach ein paar Tagen muss ich sagen dass die Funktion für mich konkurrenzlos gut Funktioniert. Allerdings gibt es Szenarien, in denen das un-/lock verzögert ausgeführt wird. Machmal öffnen die Tür erst bei 3. oder 4. Versuch.

Display hatte ich getestet, macht kein Unterschied, ebenso ist Stromsparen beim Handy ausgeschaltet
und natürlich habe ich auch mal 30s oder noch länger gewartet und immer wieder probiert.
Ja ich habe Android7/Nougat.

Wenn das Problem beim aufschließen auftritt, wird in der App bei Handyschlüssel „nicht verbunden“ angezeigt.
Umgekehrt steht da die ganze Zeit „verbunden“ und ich laufe aus der Garage ins Haus und es bleibt offen.
(Garage direkt am Haus. Allerdings hat es auch in einem Parkhaus nicht funktioniert.)

Und wie gesagt: Wenn keine App ein Problem hat außer der Tesla-App, suche ich den Fehler erst mal dort, vor allem wenn da schon so komische Empfehlungen kommen.

Ich blicke mich immer um ob das Abschließen klappt, aber bisher hat es bei mir zu 100% immer verschlossen und geöffnet per Smartphone. Hoffe es bleibt so, aber bisher echt geil nix mehr machen zu müssen. Öffnen -> Drive -> und los geht der Spaß :smiley:.

Heute ist ein Tesla App-Update reingekommen, für die die nicht aktualisiert haben evtl. mal die Tesla App updaten.

mfg

Hoffe das ich da auch noch hinkomme, denn wenn das „keyless“ länger dauert als die Karte oder das Handy rauskramen und Knopf drücken macht es keinen Sinn.

How hard can it be?

Wozu Smartphone raus holen? Das berühre ich nie beim Öffnen oder Schließen / Losfahren. Das Handy musst du als Schlüssel im Model 3 verbinden, dann geht alles ohne zu tun. Das Smartphone sogar im Rucksack liegen geht trotzdem :smiley:. Aber ich denke so klappt es bei dir auch und ich habe es falsch gelesen. Der Vorteil vom Smartphone ist echt das man nichts machen braucht, die Keykarte musst ja in die Mitte Legen zum losfahren. Das Smartphone kann ich der Hose/Tasche bleiben :smiley:.

mfg

Das habe ich doch alles gemacht/verstanden, es geht aber bei mir nicht zuverlässig.
Wenn Tesla mir den Algorithmus verraten würde, könnte ich mich ja so verhalten, das es geht, also z.B. nach dem Austeigen 2mal hüpfen und im Kreis drehen oder so :wink:

Nur weil ich das gerade gelesen habe, meine 2 Cent dazu:

Ich habe ein iPhone und es geht manchmal und manchmal nicht (das Aufsperren meines M3). Meist geht es, wenn ich das iPhone in der Hosentasche „aufwecke“ indem ich den Home-Button drücke. Immer geht es, wenn ich mein iPhone durch Fingerabdruck oder Code unlocke (die Tesla App läuft sowieso im Hintergrund, wird also nicht beendet). Manchmal auch wenn ich lange genug vor der Tür meines M3 stehe…

Das ist so, weil ich ein relativ altes 6er iPhone habe und das Bluetooth drauf hat offenbar eine Macke. Denn wenn ich Laufen gehe, habe ich permanent lästige und unterschiedlich lange Aussetzer auf meinen Bluetooth-Kopfhörer. (Ja, mit einem anderen noch älteren iPhone funktioniert dieser Kopfhörer einwandfrei, ohne Aussetzer.)

Also werde ich wohl bald auf ein neues iPhone umsteigen, dann sollte das Öffnen meines M3 auch wieder tadellos funktionieren.

Wie gesagt kann nur für Android sprechen. Habe weder die App im Hintergrund extra laufen noch sonst was. Also das Auf-/und Zuschließen geht echt erste Sahne wenn ich unterwegs bin oder auch daheim aussteige. Schade das da einige Probleme haben. Bin mit Omni-Rom 9 (Android 9, gerootet) auf einem OnePlus 5T unterwegs und habe da echt keine Probleme. Aufwecken geht bei mir wegen einem sehr schlechtem mobilem Netz nicht so gut (der Tesla hat unter dem Carport kein Mobiles Netz, ist quasi Offline) aber okay. Daheim langt ein Druck auf Öffnen in der App per Bluetooth wecke ich in immer im Haus auf wenn es nicht klappt danach ist er da. Daran ist aber nicht Tesla schuld, sondern unser geniales mobiles Netz.

mfg

Interessant, es gibt also Abstufungen des Problems.

Gelesen habe ich mal was von „Bluetooth stack abstürzen“ - ich interpretiere das so, das die Hardware (BT prozessor) abkachelt.
Dann wäre ein On/Off die Lösung und sicher auch automatisierbar.
Komisch ist aber, das BT sonst keine Probleme macht, es müßte schon ein sehr spezifischer Teil der BT SW sein die da aussteigt.

Bei mir ist dauerhaft der Schlüssel offen im Handy, wenn ich lange weg vom Auto bin steht dort „getrennt“. Wenn ich mich wieder nähere „verbunden“, dann geht es auch sofort auf. Es kommt allerdings vor dass wenn ich in der App bin und auf unser Model S switche, dass der Schlüssel verschwindet und demnach geht das Auto auch nicht auf. Der kommt erst wieder wenn ich aufs Model 3 gehe.

Lange nicht mehr passiert aber kam vor nem Monat oft vor war, dass der Schlüssel auch einfach mal so verschwand aus welchem Grund auch immer und nur durch öffnen der App wieder kam.

Ich nutze ein iPhone. Wenn ich die Tesla App geschlossen habe, schließt das Auto weder ab noch auf. Bluetooth natürlich aktiviert. Läuft die Tesla App im Hintergrund, funktioniert es meist ganz gut. Das nervt mich etwas. Abschließen tut er aber auch erst nach ungefähr 10-15 Sekunden. Da bin ich meist schon 20 m vom Auto weg. Erst dann kommt die Hupe (habe ich eingestellt) als Bestätigung. Finde ich auch viel zu lang.

M3 Lock/unlock funktioniert top bei mir zuverlässig (mit iPhone XSmax und iOS 12), aber walk way lock funktioniert bei meinem M3 nicht, auch wenn ich nur das iPhone und nicht die key card bei mir habe. Habe schon jenste Posts in amerikanischen Tesla Foren gesehen, in denen von einer Einstellung Controls > Locks > Walk-Away Door Lock die Rede ist, aber eine solche Einstellung kann ich nicht finden. Weiss jemand die Lösung?

Die Option heißt hier „beim Verlassen verriegeln“.
Interessanterweise gibt es keine Funktion „bei Annäherung entriegeln“ - geht das dann immer oder auch nur wenn die o.g. aktiviert ist?
Bei mir war die allerdings 2mal schon wieder aus, evtl. nach einem SW update und/oder absichtlichem Reboot der MCU meinerseits.

Heute hat das Verschließen zu Hause zur Abwechslung mal geklappt! (Dafür aber das Öffnen heute morgen nicht.)
Vielleicht müssen sich Handy und Auto noch aneinander gewöhnen :wink:

Alles interessant. Bei mir funktioniert es eigentlich immer, dafür muss aber wirklich die App immer geöffnet sein. Wenn die App im Hintergrund nicht läuft, Bluetooth aber an ist, kann ich weder automatisch verschließen noch öffnen.

Öffne ich die App, merke ich wie die App in das Bluetooth eingreift und die Verbindung herstellt. Das Bluetooth Symbol fängt dann an zu leuchten. (iPhone)

Klingt alles sehr gewürfelt/zufällig.

Bei mir funktioniert es, seit ich das M3 habe, immer ohne Probleme, sowohl das sich die Türen/Kofferaum sauber öffnen lassen wenn ich mit dem Mobilen ankomme, als auch das Verriegeln wenn ich weg gehe.

iPhone X iOS12, Tesla App immer geschlossen.

Gestern und Heute hat es einfach funktioniert, hingehen aufmachen, weggehen zumachen, wenns so bleibt, nehme ich alles zurück.

Ich habe dazu mal bewußt die Tesla-App aus der Liste der letzten Programme herausgewischt bzw. die App nach dem Booten des Smartphones nicht explizit geöffnet.

Schaut man unter „laufende Dienste“ im Smartphone nach, ist nämlich bereits nach dem Booten 1Prozeß und 1Dienst von Tesla am laufen.

Ich benutze ein iPhone 7 und habe eine Grobe Idee wieso es ab und zu nicht funktioniert. Ich benutze neben meinem iPhone noch eine Apple Watch, welche permanent mit meinem Handy per Bluetooth verbunden ist. Gestern war ich den ganzen Tag ohne Apple Watch unterwegs und habe gemerkt, dass das Auto ab und zu nicht direkt geöffnet wird. Erst wenn ich kurz warte oder mein Handy entsperre, funktioniert es wieder. Hier denke ich, dass es beim iPhone einen Ruhe Modus gibt, wo er nicht permanent Daten per Bluetooth sendet. Wenn ich jedoch mit meiner Apple Watch unterwegs bin habe ich nie das Problem, dass das Auto mich nicht bemerkt (Vermutlich kein Ruhe Modus).
Das Problem liegt sehr wahrscheinlich am Handy.