Impressum / Datenschutz Regeln Cookies
TFF FORUM TFF E.V. SUPERCHARGE-ME
TFF Forum

ScanMyTesla & TM-Spy

Updates wird es auf jeden Fall geben - Focus ist aber gerade wohl eher die Intergation mit TEslaLogger - wobei ich dort auch schon angemerkt habe, dass wir Filter oder ähnliches für unsinnige Werte brauchen (die hatte ich schon immer ab und zu).
Wenn Du schreibst zicken rum ist was genau gemeint?

Wurden mit der 2019.40.2.1 wieder CAN Nachrichten geändert ?

Wie zeichnet der TeslaLogger auf? In ein bekanntes Log-File Format oder anders?

  1. kann ich nichts zu sagen - habe noch ein 40.2
  2. TeslaLogger (rein local/denzentral) ist ala TeslaFi (zentral) nur das ScanMyTesla um ein online export über eine WIFI verbindung erweitert wird (später auch zwischenpuffert) und die Daten vom CanBus dann auch im TeslaLogger (Datenbank) via Grafana sichtbar sind.

Ok, also es schreibt die Daten in eine SQL Datenbank?

Oh, sorry, ich war etwas unpräzise.
Diverse Werte springen zwischen 2 Anzeigewerten. Bin gerade nicht am Auto, sodass ich nur einen aus der Erinnerung benennen kann:
Der „Evap Enabled“-Wert im HVAC-Tab (2. von oben) springt im 1 Hz-Takt von 1 kurz auf 0. Synchron springen andere Werte in diesem (und anderen Tabs) zwischen einem plausiblen und kurz einem unplausiblen Wert hin- und her.
(Ich weiß, keine große Hilfe. Werde das später mit Screenshots präzisieren)

Ja kennen ähnliches man hat auf einmal 300kWh Batterie oder nur noch 30 dann wieder richtige 74.xkWh. Das passiert aber auch mit anderen Firmwareversionen - muss an ScanMyTesla liegen oder die Werte kommen teilweise falsch vom Bus/ODB adapter.

Bzgl. DB ja eine MariaDB auf Deinem lokalen PI oder Dockercontainer.

Hier ein paar unplausible Werte:

  • Duct right
  • Duct left
  • Cabin Humidity (springt zwischen 80 und 200 %)

Auch die „PT Target active“ und „PT Target passive“ auf dem „Temps“-Tab springen


Zeigen die Werte zwischendurch etwas plausibles an oder sind die immer falsch? Was für einen Adapter hast du?

Du könntest einen kurzen CAN dump machen (lange auf den roten Aufnahmeknopf unten rechts drücken, im Menü dann nur „CAN dump“ anhaken und bei fahrbereitem Fahrzeug (damit die Inverter und alles aktiv sind) und eingeschalteter Heizung ein paar Sekunden lang laufen lassen (zum Starten/Stoppen kurz auf den Knopf drücken). Die Datei findest du dann im Ordner „ScanMyTesla“, die könntest du als Anhang hier hochladen, dann schaue ich mir das an.

Am besten wäre auch noch eine kurze Aufnahme während der Fahrt.

Das Update werde ich dann mal besser vermeiden, bis das geklärt ist…

Hab einen OBDLink LX.
Speziell die „Cabin Humidity“ zeigt auch mal 22 % an, was plausibel sein könnte.
Der CAN-Dump war in D aber Stillstand.
CANDump 2019-12-11 22-29-20.zip (247 KB)

Da dürften sich tatsächlich ein paar Signale geändert habe, nämlich genau das für die Heizung. Im DBC heißt das „VCRIGHT logging 1hz“. So wie es aussieht haben sich da ein paar Dinge geändert, die Duct temps passen nicht mehr, die Watt vom PTC ebenfalls nicht (die PTC demand aber schon).

Ich muss mir das mal in Ruhe ansehen, vielleicht ist es nur eine kleine Verschiebung die man mit etwas rumprobieren wieder hinbekommt.

Kannst du mir morgen auch einen Dump vom Fahren schicken? Ich würde gerne die Power-Signale prüfen.

Idel wäre auch, wenn du die Anzeige für den Kühlkreislauf-Modus (seriell/parallel) prüfen könntest. Dazu muss der Akku aber über 30°C erreichen, damit umgeschaltet wird. Am besten wäre vermutlich ein Ladevorgang am Supercharger bis der Akku bei etwas über 35°C ist, dann ein Stück fahren. Dann sollte zuerst im seriellen Modus über den Kühler gekühlt werden, bei 32-33°C müsste dann die Umschaltung auf parallel erfolgen.

Von beiden Zuständen bräuchte ich eine Schnappschuss.

Ich habe nämlich festgestellt, dass auch beim VCFRONT logging 10hz (von dort kommt auch der Wert für seriell/parallel in SMT) sich wieder etwas geändert hat. Soll und Ist-Wert des Umschalventils passen jetzt nicht mehr zusammen, zumindest in deinem Log. Das war bisher immer ein Winkelwert zwischen 5 und 135 Grad, in deinem Log steht das Soll auf 100 Grad, das ist auf 86 Grad.

Seriell/parallel ist nur ein binärer Wert (0=seriell, 1=parallel), der davon unbetroffen sein kann, aber das Ventil wäre interessant, weil man da alle vier Modi des Kühlsystems verfolgen kann:

  1. Ventil auf 135°: Kühlkreislauf seriell, Kühler wird zu 100% umgangen -> Batterie aufheizen mit Abwärme von Motor/Inverter
  2. Ventil auf 95°: Kühlkreislauf seriell, Kühler wird nicht umgangen -> Kühlung von Batterie und Motor/Inverter (z.B. nach Supercharging)
  3. Ventil auf 45°: Kühlkreislauf parallel, Kühler wird zu 100% umgangen -> Batterie kann über Klimaanlage gekühlt werden, Motor/Inverter brauchen keine Kühlung (kommt oft beim Supercharging vor)
  4. Ventil auf 5°: Kühlkreislauf parallel, Motor/Inverterkreislauf läuft über Kühler, Batteriekreislauf kann über Klimaanlage gekühlt werden (Standard beim Fahren wenn Batterie warm ist und die Motoren auch)

Zwischen 1 und 2 und 3 und 4 gibt es fließende Übergänge, man sieht schön, wie die Temperaturen fallen, wenn auf den Kühler umgeschaltet wird.

Hier sind noch zwei Dumps währends des Fahrens.

PS. Dauert einige Zeit bis ich an einem SuC vorbeikomme.
CANDump-2019-12-12.zip (463 KB)

Wenn ich den TAB „BMS“ hinzufüge, werden keine Daten angezeigt, dir Seite bleibt schwarz… An was kann das liegen?

Du musst die gewünschte Paramter selbst von den anderen Tabs zuordnen

BMS wäre die Anzeige der Spannungen und Temperaturen aller Zellenblöcke, das Signal gibt es aber seit Frühjahr nicht mehr. Die verfügbaren Akku-Daten findest du im Battery-Tab.

Da hat uns Tesla ein schönes vorzeitiges Weihnachtsgeschenk beschert:

Die ganzen VCFRONT logging-Werte sind total durcheinander, Heizung muss ich mir noch anschauen, vermute aber ähnliches. Es ist nicht klar erkennbar ob nur Startbits geändert wurden, oder ob auch die Umrechnungsfaktoren andere sind.

Ich habe bei mir schon mal vorsorglich das WLAN gelöscht, damit er sich das Update erst mal nicht holt.

Wenigsten die Leitungswerte funktionieren noch, , ebenso Ströme und Batterietemperatur.

So, nun habe ich es auch installiert - das Einschlafen lassen war ein Problem, alles nach Anleitung und trotzdem nichts 30min lang, WLAN hatte ich im Fahrzeug auch noch ausgeschaltet, Kindersitz ausgebaut usw. - dann habe ich noch den AP im Haus kurz ausgeschaltet, kurz drauf hörte ich das klonkk.
Allerdings hat sich das Fahrzeug beim Zusammenstecken der CAN-Verbindung sofort wieder eingeschaltet (Klonk-klonk) und nicht erst als ich die Bremse getreten habe, Fehlermeldungen gabs bisher keine (Schwitz las nach).
Da ich schon die .40 drauf habe, zappeln natürlich einige Werte wie oben beschrieben,

Problematisch ist es, den Deckel der Mittelkonsole mit dem eingesteckten Kabel wieder zuzukriegen - da muß man mehr Kraft anwenden das Kabel so zurechtzudrücken als mir lieb ist.

Ich finde das USA Adapterkabel auch hochwertiger als aus DE.

Wenn jemand eine Sammelbestellung starten möchte, dann bin ich dabei.

Ich habe schon ein Angebot aus den USA geholt ($30 Kabeladapter + $30 Versand + kein Zoll + 19% Einfuhrsteuer) .
Wenn wir nur 4 Stück bestellen, dann sind wir unter 150 € Warenwert und müssen nur 19% MwSt beim Zoll zusätzlich bezahlen.
Dann bei 4 Stück; 4 x $30 Kabeladapter + $30 Versand = $150 = ca. €135 +19% MwSt. €26 = €161

€161 : 4 = ca. €40 für ein Adapterkabel + Versand €4-5
Der Sammelbesteller bekommt das Adapterkabel für ca. €40, die anderen für 44/45.
Fair wäre natürlich, dass wir (die anderen 3 Personen) dem Sammelbesteller €50 geben, damit er für die Arbeit „belohnt“ wird :smiley: :mrgreen:

VG Tenker

Eine erste gute Nachricht für alle mit 2019.40.2.1:

Die Anzeige der PTC-Heizleistung, die auch durcheinander geriet, sollte sich einfach richten lassen. Es gibt eine CAN ID mit Spannung und Stromstärke, daraus kann man die Leistung super berechnen. Ich bin diesbezüglich schon mit dem Entwickler in Kontakt.

Was jetzt dringend nötig wäre ist ein CAN Dump mit parallelem Kühlkreislauf (Series/Parallel=1). Entweder nach Supercharging, oder was auch geht ist einen lauwarmen Akku bei Kälte ca. 90 min laden, dann abstecken und kurz fahren. Solange die Drive Units kalt sind, sollte der Kreislauf parallel sein.

Oder Akku über 30 Grad bringen…

Falls die Anzeige nicht mehr geht: unterschiedliche Coolant Flow Raten (über 1 lpm Differenz) Battery/Powertrain sind ein.Indiz fpr parallelen Kreislauf. Dann ein paar Sekunden CAN dump reicht.

Nachtrag:

Es wären auch CAN dumps von folgenden Situationen hilfreich:

  1. Rekuperation mit kaltem Akku, wenn die Motoren nach aktiv mitheizen (Reku auf Standard, ganz vom Gas weg bei >80 km/h): zum checken, ob die „heat power“ Werte noch korrekt sind (gibt es noch nicht in SMT, CAN IDs und Skalierung der Werte sind aber bekannt).

  2. Volle Beschleunigung von 0-1xx km/h: Leistungswerte, Drehmoment prüfen ob korrekt (nach ersten Dumps nach wie vor korrekt)

  3. A/C Ladevorgang: 10-15 Sekunden während laufendem Ladevorgang mit 16 Ampere

  4. Supercharging mit Akku-Temperatur über 50°C: An dem Punkt, wo plötzlich die Battery Inlet Temp abfällkt, auf Aufnahme drücken-> zum Prüfen, ob Wert für Chiller Demand noch funktioniert. Ebenso sollte dann der parallele Kreislauf aktiv sein.

  5. Klimaanlage (Außentemperatur 4°C oder höher): Auf manuellen Modus schalten, A/C Kompressor aus, mittlere Gebläsestufe, Temperatur LOW, dann Aufnahme starten, A/C Kompresor manuell einschalten, ca. 20-30 Sekunden laufen lassen, dann Aufnahme stopp, ein paar Sekunden warten, neue Aufnahme starten, A/C Kompressor aus, ein paar Sekunden Aufnahme weiterlaufen lassen, dann stopp -> A/C Daten

  6. Dasselbe mit Heizung (manueller Modus, A/C aus, Start in LOW, Aufnahme starten, dann auf HI, nach 20-30 Sekunden stopp).

  7. CAN dump bei ausgekühltem Fahrzeug (>12 Stunden Stillstand, möglichst an Tag ohne Sonne mit gleichmäßiger Temperatur, bzw. am frühen Morgen, kein Ladevorgang oder vorheizen): Temperaturwerte. Ca. 15 Sekunden sind genug. Es geht auch ein Garagenfahrzeug, es muss nur lange genug gestanden sein.

Ich kann vorher/nachher Vergleiche zu meinem Fahrzeug, das nach wie vor auf 2019.36 läuft, ziehen und versuchen, veränderte Werte wiederzufinden. Wenn jemand mit SavvyCan oder ähnlichem aufzeichnen kann (z.B. mit Macchina M2 und M2RET, EVTV CANDue oder andere SocketCAN kompatible Adapter), wäre das sehr hilfreich, da das Programm ein paar Dinge mehr kann als der CANbus Analyzer. Die Dumps von SMT gehen leider nicht mit SavvyCAN.