Model S Long Range (Raven): ScanMyTesla Output

Nachdem ich gestern mein neues Model S Long Range abholen durfte, hab ich gleich das OBDLink MX+ dongle verbaut und noch im Delivery Center den ersten Snapshot gezogen.

Dieser Thread soll dazu dienen die Batterien der MS Long Range über die Zeit zu tracken.

Snapshot: 30/09/2019 - ODO: 18km


1 „Gefällt mir“

Danke für den Screenshot eines neuen MS. Jetzt kann ich meine aktuellen Werte (40Tkm) besser einschätzen.


Snapshot: 06/10/2019 - ODO: 911km

Von der gestrigen Fahrt noch die letzten 20 Minuten mitgeloggt. Habe mal Torque (N/m) und PS (HP) auf einen Plot gebracht. Interessant finde ich wie wenig der Heckmotor zum Einsatz kommt (Range-Mode = OFF), nur bei grosser Leistungsanforderung oder Rekubedarf schaltet er zu (Synchron zu Torque-Bias > 0).

@solaris,

gratulier zu deinem neuen (tollen) Fahrzeug!

Wollte dich nur fragen - wie bekommst die die Logdaten von ScanMyTesla in der Excel-Tabelle ausgewertet?

Bei mir werden extrem lange csv Listen ausgegeben (ich glaube jede Sekunde ein Wert) und die bekomm ich einfach nicht so umgewandelt, dass ich z.B. einen Graphen für die Ladeleistung in Zusammenhang mit dem SoC erhalte.

Danke!

Danke :slight_smile: Ja habe sehr Freude an meinem neuen MS.

Ja, Excel und Konsorten (z.B. Google Sheets) sind chancenlos bei dieser Datenmenge.

Ich verwende daher Gnuplot auf Mac OS, einfach zu Bedienen über Kommandozeile:

gnuplot> set datafile separator ','
gnuplot> set key autotitle columnhead
gnuplot> set y2tics
gnuplot> set ytics nomirror
gnuplot> set xlabel 'Time'
gnuplot> set ylabel 'N/m'
gnuplot> set y2label 'HP'
gnuplot> plot "/Volumes/GoogleDrive/My Drive/Tesla/ScanMyTesla/20191006-911km/Perf 2019-10-06 11-09-21.csv" using 1:4 with lines, '' using 1:6 with lines, '' using 1:5 with lines lt rgb 'red', '' using 1:7 with lines axis x1y2, '' using 1:8 with lines axis x1y2, '' using 1:9 with lines axis x1y2
gnuplot> set terminal png size 4500,700
gnuplot> set output 'perf-20191006.png'
gnuplot> replot

Ich bin sicher für Windows-User gibt es mehr Auswahl, z.B. datplot.com/ (Gratis, habs nicht getestet)

@solaris007: Danke dir - werd ich testen!!

hallo nochmals,

kann es sein, dass bei mir nicht alle Daten ordentlich geloggt werden?

Das sieht bei mir so aus:

Sieht für mich so aus als ob dein TeleFon oder Tablet nicht nachkommt und daher einzelne Pakete weggelassen werden. Der Zeitunterschied zwischen den Paketen ist 1msec glaube ich, hast also nicht viel verloren.

Übrigens loggt er für jede Spalte auf einer eigenen Zeile bei gleichem Time Code

Ich habe übrigens bisher nur den Perf Tab mitgeloggt beim fahren. Du hast wie es scheint einen anderen Tab (Batterie?) geloggt. Kann gut sein dass da die refresh rate geringer ist als bei Perf. Versuch Mal eine Fahrt mitzuloggen und schau ob Unterschiede bestehen.

kann auch gut sein, dass mein „alter“ OBD Bluetooth Adapter das nicht mehr schafft - vielleicht muss ich mir da mal einen neuen zulegen!

Aber ich werde es versuchen - wie du richtig vermutet hast, habe ich den Tab „Battery“ geloggt! Muss mir einen Tab suchen, bei dem ich SOC und BMS Charge drauf habe!

Danke dir!

@waltertirol
Einige Daten werden in unterschiedlichen Zeitabständen gelogt.

@solaris
Danke Dir für Graph und Tool :slight_smile:

Ich spiele gerade auch mit SMT rum. Habe zwar einen alten S85, steuere meine Erfahrungen hier aber gerne bei.
Habe vorgestern bei einer längeren Fahrt mal die gesamte Fahrt geloggt. Und zwar den „All“ Tab!
Nach 5 Stunden hatte ich eine .csv Datei von 360MB auf dem Handy.
Nach Import in den Excel (ja, das bringt viele PCs an die Grenze des machbaren) und Speichern in einer .xlsx Datei blieben davon noch 50MB übrig.
Die Tabelle hat ca. 300 Spalten und ca. 1 Million Zeilen, ist aber nicht voll belegt. Das heisst nicht jeder Wert wird mit der gleichen Häufigkeit gemessen. Die erste Spalte ist übrigens die Zeit in ms seit Start des Logfiles.
Ich habe noch viel Analysearbeit vor mir, aber hier mal eine erste Grafik mit dem Verlauf der Batteriespannung über die 5 Stunden (inkl. 1x am SuC).

1 „Gefällt mir“

Snapshot: 12/10/2019 - ODO: 1795km

Moin Solaris,

Wie sehen die Werte bei Dir nach 8 Monaten aus?
Habe heute mal seit langem wieder auf 100% geladen und komme nach 19.000km nur noch auf 560km RR.
Leider hab ich nicht die Hardware, um die Usable Full Pack auszulesen.

Gruß Litochen

Snapshot: 24/11/2019 - ODO: 5167km

  • Ladung 100% a/c
  • Nominal Full Pack gleich bei 97.7
  • Rated Range: 581
  • Cell Imbalance: 11 mV


1 „Gefällt mir“

Snapshot: 06/07/2020 - ODO: 9783km

  • Ladung 100% a/c
  • Nominal Full Pack von 97.7 auf 97.8
  • Rated Range: 581
  • Cell Imbalance: 11 mV


1 „Gefällt mir“

Sieht ziemlich gut aus.
Hast Du nach 10.000km keine Degradation? Wenn Du auf 100% lädst zeigt er dann 581km an?
Wird Usable Füll Pack nicht mehr angegeben?
Bei 10.000km hatte ich nur noch 573 RR. Und nun bei 20.000km 560km RR…

Hast Du nach 10.000km keine Degradation?

Laut teslafi scheint die Degradation unter 1% zu sein.

Wenn Du auf 100% lädst zeigt er dann 581km an?

Ja

Wird Usable Füll Pack nicht mehr angegeben?

Hatte ich noch nie in Scan My Tesla. Nominal Full Pack = Usable denke ich.

Bei 10.000km hatte ich nur noch 573 RR. Und nun bei 20.000km 560km RR…

Was ist dein AC vs DC Ladungsverhältnis? Ich habe 2/3 AC (zuhause, 8kw) und 1/3 DC (Supercharger), Ladestand wann immer es geht zwischen 20 und 80 Prozent gehalten. 100% Ladung nur sehr selten für längere Trips.

Du scheinst einen echt guten Akku erwischt zu haben…

Blockquote
Hatte ich noch nie in Scan My Tesla. Nominal Full Pack = Usable denke ich.
Blockquote

Ja doch. Hier von einem allerersten Screenshot
Usable
Der Wert gibt an, wie viel Du aus Deiner Batterie rausbekommen kannst.

Blockquote
Was ist dein AC vs DC Ladungsverhältnis? Ich habe 2/3 AC (zuhause, 8kw) und 1/3 DC (Supercharger), Ladestand wann immer es geht zwischen 20 und 80 Prozent gehalten. 100% Ladung nur sehr selten für längere Trips.

Was auf den ersten 6.300km passiert ist, kann ich nicht sagen. Habe ihn als Loaner gekauft. Seit ich ihn habe, habe ich erst 15%DC geladen. Fahre nur auf Lässig und halte die Batterie zwischen 20 und 60,70%. Dreimal habe ich erst auf 100% geladen. Also wirklich sehr schonend.

Bin etwas unter dem Durchschnitt hier.

Hab mir letzte Woche die Sachen zum Auslesen bestellt. Mal sehen, was sich ergibt…