MCU Problem / Emmc fail - Wer hier hat das Problem?

I have never tried this myself. But as far as I have read/heard you cannot charge over 20% with a broken emmc or missing tegra yes.

Original Tesla 1054968-02-B - PCBA, EU LTE CONNECTIVITY, UBLOX GPS

No.

Newer (± 2015) SIM cards should work on 4G already, but some older cards need replacement. I only do the modem swap when the car has external SIM, when the SIM is internal you should have the upgrade done by Tesla SeC/Ranger.

I don’t know exactly, I have never actually timed this, but maybe someone here can do this experiment.

That is not normal, the new LTE modem should be able to fall back to 3G just fine. Works like this in my car, and many others. Maybe one of your antenna’s is not connected properly?

Also: A new LTE/4G modem with old (3G) SIM card works just fine, but stays on the 3G network only of course.

@LuckyLuke: Thank you very much for your efforts! It could happen that I will need to come to Eindhoven. My Model X shows some indications for an eMMC death in near future: Display gets very hot often, reacts very slow/laggy, web browser does not open any website any more, speaker volume cannot be adjusted for some minutes, maps (not satellite) do not load any more although LTE connection ist good.

@all: Hat schon jemand einen MCU-Tausch bei Tesla erfolgreich bei der Allianz Anschlussversicherung abgerechnet?

Hi LuckyLuke and thank you so much for your work and your explanations here in the board.
I have just another question.

Could you say something about the increasingly file size, the Croatian was talking about? If this fact is correct for my opinion it would make a lot of sense to replace the eMMC with a chip with 16 / 32 / 64 GB I think? But you wrote an 8 GB chip with higher industrial quality will solve the problem for car life time. And you don’t recommend a chip with more than 8 GB.

Is that was the Croatian mentioned just a rumour or a fact?

Thank you once more and you got an email from me regarding the MCU disassembly instruction you was talking about.

Meine MCU wurde letzte Woche getauscht und über die Allianz abgerechnet.

Hat wieviel gekostet? Welche Version der MCU wurde eingebaut?

He is correct in the fact that old firmwares were much smaller (started at around 300MB if I recall correctly), and these firmware files slowly grew to 1GB since late 2018. However: The partition size (and thus the maximum the firmware size can become) has always been fixed to 1GB.

This is how the partition table looks like on a MCU1:
mmcblk0p1 (1GB) : Firmware Bank A
mmcblk0p2 (1GB) : Firmware Bank B
mmcblk0p3 (128MB) : /var (this includes the unique key/certificate files, and some settings)
mmcblk0p4 (5,x GB) : /home (this holds all the cache, user profile settings, etc

Whenever an update downloads it downloads to the offline Firmware Bank, when that is done you get the yellow clock and „update ready“ signal. Then when you install it it starts updating all the systems inside the car, switches the offline Firmware Bank to online and then it reboots to the new firmware.

Yes: the firmwares have become bigger, but Tesla will have to keep them at 1GB maximum because of the partition index.
No: putting in a bigger chip will not improve anything unless you want to root your car and add a extra partition for your Linux or hobby stuff :wink: (which would be smarter to keep on USB drive for several reasons anyway).

1 „Gefällt mir“

Gekostet hat es nichts (da Allianz). Ohne hätte es ca 2500 zuzüglich MwSt. gekostet. Teilenummer: 1045006-03-D

@LuckyLuke: Ok, thank you, very interesting.
But a larger chip and a bigger partition for the Firmware Banks A/B wouldn’t make sense relating to a better wear levelling performance? And may be Tesla could change the partition index to enlarge these partitions in the future?

Interessant, denn bei mir wurde die Teilenummer 1045006-03-H verbaut.

Wie lautet denn die vollständige Beschreibung deiner MCU laut Auftrag/Rechnung?
Bei mir steht
LTE MCU JPN/HK/Macau/Taiwan/SK(1045006-03-H)
Gekostet hatte dieses einzelne Teil 2.198,35 € zzgl. 21% MwSt. (SeC Groningen [NL])

Die komplette Bezeichnung in der Rechnung ist: LTE MCU JPN/HK/Macau/Taiwan/SK(1045006-03-D) zum Preis von 2.235,29 zzgl. 19% MwSt.

You definitely do not want change things like partition size to something different then Tesla’s own settings.

Wear leveling is done by the controller in the chip, changing the partition size in the user space of the chip will not have any impact on wear leveling.

In theory Tesla could change the partition size yes, but I highly doubt they would ever do that. It would require a lot of moving of data over the emmc chip to re-arrange things. They would send hundreds maybe thousands of already dying emmc’s over the cliff.

Okay, thanks!

Ich war heute (gestern) beim Lucky Luke und habe meinen Chip vorsorglich tauschen lassen.

Scheinbar war es noch gerade rechtzeitig. Ich hatte in letzter Zeit mehr und mehr das Gefühl, dass die Bugs sich häuften. Diesen Eindruck hat mir Loek mit seiner Einschätzung bekräftigt: „Reading the chip now, data is good, but it is very slow so probably already at its end of life. Takes a little longer to read the full chip. I will keep you updated.“

Meins Symptome waren z.B.: Software-Update nur 1x kurz angezeigt (dann nie wieder was davon gesehen) Spotify-Hänger, keine Namen aus dem Bluetooth-Telefonbuch mehr angezeigt (nur die Nr), Browser zeigte nur noch ein weißes Blatt. Musste etwa 1-2x pro Woche rebooten (starke Schwankung), Grafikfehler. Insgesamt also so unklar und schlecht zuzuordnen wie hier im ganzen Thread beschrieben.
Das Thema kenne ich wie sicher viele hier von dem Video von Car Guru aka Rich Rebuilds. Seitdem immer wieder dran gedacht, wann und wie ich das Problem angehen könnte. Als ich am WE diesen Thread sah, hab ich kurzentschlossen einen Termin in Eindhoven gemacht.

Das Ganze war natürlich etwas spannend (vor allem weil ich auch noch kaum geschlafen und nichts gegessen hatte, oje… ) einfach so einem Fremden den Schlüssel zu meinem Tesla zu geben, der dann prompt die Batterie ausstöpselte, so dass kein App-Zugriff mehr möglich war… :open_mouth: :smiley:

Aber lasst euch sagen, der Luke kommt auch persönlich so professionell rüber wie hier im Forum. Der Ablauf ging ungefähr so:

  1. Einen Tag vorher hab ich die Innenverkleidung ausgebaut, so dass die MCU nur noch mit einigen Schrauben gelöst werden braucht, aber der Wagen noch fährt und normal lädt. Dieser Schritt ist optional und spart 250€. Eine Anleitung schickt Loek einem, für alle die noch nicht das Service Manual haben :wink: . Ausserdem gibt es ja noch diverse Videos zum MCU-Ausbau im Netz. Ich empfehle DRINGEND 1-2 dieser aufblasbaren Hebekissen für 10€ aus der Grabbelkisten im Baumarkt. Das macht es sehr leicht and die Schrauben hinter der oberen Abdeckung zu kommen.
  2. Ich kam Nachmittags in Eindhoven an. Der Wagen kam an die Ladesäule in einem abgeschlossenen Hinterhof für die umliegenden Wohneinheiten. Schlüsselübergabe, 2-3Worte gewechselt, Nummern getauscht, Tipps zur Wartezeitüberbrückung (Cafes in der Nähe) bekommen und los.
  3. Weit bin ich nicht gekommen und viele Cafés hatten zu der Zeit gerade zu. Bin dann irgendwo gelandet (nach etwas Spaziergang zurück und 200m weg von Loeks Haus), hab etwas Kaffe getrunken und Kram am Läptopp erledigt. Zwischendurch Statusmeldungen per Textnachricht. „Done“, „Success“ :smiley: Ich hatte nicht das Gefühl, dass das alles sehr lange gedauert hat. Die Zeiten die er angibt stimmen recht präzise. Der weiß was er da tut.
  4. Als ich wieder bei ihm ankam, gabs eine Tüte mit dem alten Chip, einer SD-Karten mit den ausgelesenen Daten (gucke ich später mal an…) und einen kurzen Überblick gemeinsam über das laufende System. Sah alles top aus. Hab bar gezahlt; die Rechnung kam 7,5 Minuten später per Email :wink: Der Mann ist auf Zack.

Mein erster Eindruck ist, dass das System jetzt wieder schneller reagiert. ABETTERROUTEPLANNER geht wieder, auch wenn der Browser noch immer langsam ist, aber ES LÄUFT. Meine Kontakte konnte ich ohne Probleme nochmal neu importieren. Beim Telefonieren werden die Namen wieder angezeigt, nicht nur die Telefonnummern. Ich muss das natürlich noch einige Tage beobachten, bin aber jetzt schon sowas von heilfroh (!), dass ich nach Eindhoven gefahren bin. Dieses Damoklesschwert kann ich hoffentlich/voraussichtlich abhaken.

Fazit: ich bin SUPER zufrieden mit der Arbeit von Loek. Den Kontakt kann ich nur wärmstens empfehlen. Ich empfehle auch nicht erst darauf zu warten, dass die MCU stirbt.
Bin gespannt wie sich das System die Tage verhalten wird und ob ich wieder Updates bekomme!
Dank U wel Loek!

1 „Gefällt mir“

Besten Dank für den super Bericht!
Das hört sich echt gut an.
Am interessantesten fand ich eigentlich, daß der Browser wieder geht. Also scheint ein eMMC Tausch doch die Performance irgendwie wieder anzuheben, zumindest etwas?
BITTE BITTE poste in 3-4 Wochen hier nochmal, ob es weiterhin ok ist, oder ob nach einiger Zeit wieder alles so blöd ist wie vorher, das wär super interessant zu wissen!

Wie schonmal erwähnt: Die von dir beschriebenen Browserprobleme sind kein Anzeichen für eine sterbende MCU. Diese Probleme treten auch bei MCU0/1 mit neuem Speicherchip auf und werden nach etwa einer Woche ohne MCU-Reset wieder kommen. Seit V10 braucht es meist 2 Resets nacheinander damit der Browser wieder funktioniert. Die anderen Symptome klingen aber plausibel. Danke für Deinen Bericht.

1 „Gefällt mir“

Wird beim Wechsel des Chips dessen Zustand ausgelesen? Ich denke an so Dinge wie Schreibzyklen oder neu gemappte Blöcke.

Leider verraten dir eMMCs und SDs sowas nicht.
Es gibt einige wenige proprietäre Ansätze sowas wie S.M.A.R.T. zu implementiern, mein letzter Mailwechsel mit einem Hersteller ist aber schon > 1 Jahr her und war ungefähr so:
Ich: „In einer Note hab ich gelesen, da gibts Feature X (wie S.M.A.R.T.), gib mal API, Doku, etc.“
Hersteller: „Murmel murmel, wir sind noch nicht soweit, wird NDA-bewehrt, wir halten dich auf dem Laufenden.“
Seitdem nix mehr.

Ganz grossartig auf jeden Fall.
Ein ganz wichtiger Schritt für die Community.
Vielen Dank an die Pioniere und an LuckyLuke.

Tesla kennt die „erase cycles“, also geht’s scheinbar doch irgendwie. Siehe Tesla Model S mit RWE Ladesäulen kompatibel?

Toller Bericht, danke M3vince.

Was kostet das bei Lucky Luke?
Hab die letzten paar Seiten überflogen, aber die Kosten nicht gesehen, möglich, dass ich drüber gelesen habe, verzeiht in dem Fall…