Impressum / Datenschutz Forumsregeln
TFF FORUM TFF E.V. SUPERCHARGE-ME
TFF Forum

Laden mit PV-Überschuss mit Keba und smartED Software

Edit während ich am Antworten war :slight_smile:

Deshalb wird für 30 Sekunden nach dem Start nix geregelt, das meinte ich mit „ich fürs Starten und Stoppen jeweils 30s Regelsperren eingebaut habe“. Den von Dir geschilderten Fall hatte ich anfangs :slight_smile:

Ah okay…auch beim ersten Start. Manchmal überlese ich gern etwas.

Meine Einstellungen sind wie folgt:

  • Activation at 4500 W (keine Phasenabschaltung, nur 3-phasiges Laden)
  • Max charging phases 3
  • Min charging current 6000 mA

Nachfolgend eine Grafik meines letzten Ladevorgangs (Auto und Haus müssen addiert werden für den Totalverbrauch)

Mit den optionalen Einstellungen meinte ich nicht, dass gar nichts eingespiesen oder bezogen werden darf, dass dies nicht zu bewerkstelligen ist, ist logisch. Ich dachte eher daran, dass man die Sicherheitsmarge einstellen kann.

War nur eine Idee, ich kann auch so damit leben.
Auf jeden Fall möchte mich für die SW bedanken (und dankbar bin ich auch Keba, dass sie die API offen legen, das macht Mennekes z.B. nicht).

Laut Deinen Diagramm beziehst Du 400W aus dem Netz beim Laden? Da stimmt was nicht. Ich habe es eben mit 6kW probiert und da pendelt der Verbrauch/Einspeisung maximal um die +30W und -30W. Woher kommen die 400W? Wo hast Du das EnergyMeter verbaut? Schick mit mal via PN ein Screenshot von Deinen Settings.

kurzes Update in diesem Thread:

Die edl SW von smarted regelt in 60mA-Schritten, das Model S leider nur in 1A-Schritten (1000mA). Zudem regelt das MS zu früh hoch, somit wird zu viel Energie bezogen. Das MS regelt bei ca x500 auf das nächste Ampere hoch.
Das sieht dann so aus:

PWM-Signal der Keba => Tesla
6420 => 6200 (zuwenig, unkritisch)
6480 => 7200 (zuviel, kritisch)
7440 => 7200 (zuwenig, unkritisch)
7500 => 8200 (zuviel, kritisch)
8400 => 8200 (zuwenig, unkritisch)
8460 => 9200 (zuviel, kritisch)
9420 => 9200 (zuwenig, unkritisch)
9480 => 10200 (zuviel, kritisch)
10440 => 10200 (zuwenig, unkritisch)
10500 => 11200 (zuviel, kritisch)

Daher stammen die bis zu 500W (700mA x 240V x 3), welche zuviel bezogen werden.
Ich hab dies Tesla gemeldet, sobald ich etwas erfahre geb ich Bescheid.

PS: Ich weiss ich mach da teilweise ein Durcheinander mit Strom/Spannung/Leistung/Energie. Fakt ist, geregelt wird der Strom (Keba-Ladebox, Model S), den Akku „befüllen“ wir mit Energie, dargestellt in Grafiken wir häufig Leistung.

Bug 2 (nicht-wieder-hochregeln) ist behoben mit FW 6.2 2.5.36
Bug 1 (zuviel-Strom-ziehen) ist leider noch nicht behoben.

Ich bleib am Ball…

Das kann ich jetzt bestätigen!

Nach dem Abschalten der Ladung steht wieder 32A im Display!

Allerdings gab es mehrfach den Overloadfehler.

Bug 2 (nicht-wieder-hochregeln):

Ich habs noch mit einem 2ten Tesla getestet, mit Version 6.2 (2.5.21) war der Bug noch vorhanden, mit 6.2 (2.5.36) ist der Bug behoben.

Mit Hilfe von Andreas aus der Schweiz ist ab dieser Version (1.4.89) auch der Workaround zum Tesla Bug ‚overload/power mismatch‘ in den Smartchargingcontroller eingebaut.

Vielen Dank an Andreas für detaillierte Messungen und die Logik, wie man das Problem temporär umgehen kann. Mit der Einstellung „Tesla Workaround“ ON in den Einstellungen, werden beide Workarounds aktiviert. Derzeit ist noch nicht zu 100% sichergestellt, dass der ‚increase current workaround‘ von Tesla behoben wurde.

Wichtig: Die Umgehung des ‚overload/power mismatch‘ Bugs hat NUR für Teslafahrer zur Folge, dass nicht mehr genau an der Überschusskurve geladen werden kann, wie bisher gewohnt. Die feine Abstufung in 60mA Schritten ist derzeit so nicht möglich. Es sind aber auch keine 1A Schritte. :mrgreen: Die Regelgenauigkeit ist von der Ladeleistung abhängig.

Wir, alle die deine SW nutzen dürfen, haben zu danken. Echt klasse deine SW und wie schnell du auf Probleme reagierst und Lösungen/Workarounds implementierst.
Jetzt hoffen wir, dass auch Tesla liefert…

Vielen Dank.

Hallo

Bei mir ist der Fehler trotz der Änderungen leider noch da:

KEBA-Wallbox Log Eintrag:

Smart Charging Controller 1.4.90 Log Eintrag:

:cry:

Hallo

Ich kann vermutlich gutes vermelden.

Danke einer neuen Software für die Keba (KEBA P20 v 2.5a2) ist das Problem wohl behoben.

Nach diversen Test`s ist bei mir kein Fehler mehr aufgetreten.

Ein Dank an Nico und KEBA.

Endlich braucht man sich keine Sorgen mehr zu machen, ob er lädt, oder nicht.

Gruß

Kaju

Hi

Ich hab kürzlich auch aufgerüstet und die Phasenumschaltung eingebaut. Auch bei mir kam der Overload-Fehler. Bei wechselhaftem Wetter und häufigen umschalten der Phasen taucht dieses Problem bei mir auf. Die Box erholt sich die ersten Mal noch, wenn es zu oft auftritt, geht nichts mehr.
Wo bekommt man die neue FW her? Auf der KeContact-Page ist immer noch die 2.3a3.

Gruss

Du hast PN

Hi

Ich habe sie direkt von KEBA/Nico bekommen.

Gruß

Karsten

PS: Hat sich ja schon erledigt, er hat selbst geantwortet.

Hi

Auch bei mir ist das Keba-Overload-Problem mit der Keba P20 FW v2.5a2 behoben.

Der Bug 1 bei dem der Tesla zuviel Strom zieht, ist leider noch nicht behoben. Ich hab allerdings von Tesla eine Nachricht erhalten, dass ich bis Ende Juni eine FW haben sollte, bei der dies behoben sein soll. Bei 7.1 2.20.45 ist dies noch nicht der Fall.

Gruss
MrTux

Das kann ich bestätigen. Danach nehme ich den Tesla-Bug-Fix aus der Sofware (SmartChargingController) raus.

Gestern FW 2.28.19 erhalten und heute ein paar kurze Tests gemacht und mit der edl-SW mit ausgeschaltetem Tesla-Bug geladen. Ich kann vermelden, Bug 1 ist nun auch behoben, somit zieht das Model S nicht mehr zuviel Strom. Regelt noch nicht mit 60mA-Schritten, aber immerhin bezieht er keine Energie aus dem Netz. Wenn es wieder schönes Wetter ist, werde ich es ausgiebiger testen.

Bug 2 (nicht-wieder-hochregeln) ist behoben mit FW 6.2 (2.5.36)
Bug 1 (zuviel-Strom-ziehen) ist behoben mit FW 7.1 (2.28.19)

Hi,

ich möchte meine EWS Box auch an IP Symcon anbinden. Wie hast du das gemacht? :slight_smile:

LG,
Peter