Keine Mediaplayer für USB!?

Hi,

muss gestehen, dass ich in den letzten 12 Monaten noch keinen USB Stick eingesteckt habe.

Jetzt habe ich V9 drauf und wollte das mal probieren, aber nix…

Mit zwei Sticks probiert…
MP3s in das Hauptverzeichnis kopiert und einen Ordner mit MP3s angelegt und in der Mittelkonsole neben dem 12V Anschluß in den USB Port gesteckt.

Leuchte des Sticks flackert ein paar Mal, im übrigen 8GByte FAT32 formatiert, und das war es.

Ich habe im Player keine Menüpunkt USB, nur das übliche…Radio, Spotify, TuneIn und Handy.

Bin ich jetzt schon hierfür zu schusselig ?

Danke

Gorg

Der USB support wurde eingestellt, weil ein Kunde gedroht hat, Tesla zu verklagen, wenn er nicht auch sticks mit 40 000 songs performant unterstützt.

SCNR

Was jetzt nicht unbedingt ein Problem sein müsste, man sollte die Dinger halt nicht unbedingt über Fat32 und als Flatfiles rumliegen lassen und auch allein auf den Kernel stützen…

Hi,
gibt es eventuell doch noch konstruktive Ideen?

Habe es mit zwei weiteren Stick probiert.

  • FAT formatiert
  • eine .mp3 in das Hauptverzeichnis
  • in der Konsole neben dem 12V Anschluß in USB gesteckt
  • LED des Sticks flackert, also vermute ich Erkennung

-> NICHTS

Muss ich den MediaPlayer irgendwie manuell starten oder erscheint der irgendwo im Menü?
In dem Handbuch finde ich nichts brauchbares !?

Der USB-Stick, den ich unter v8 für Musik verwendet habe, funktioniert bei mir auch unter v9 wie gehabt. Damit will ich nur sagen, dass die Funktion grundsätzlich noch vorgesehen ist.

Die USB Unterstützung im Tesla ist generell k#cke, funktioniert aber rudimentär.

  • Media Player starten
  • USB einstecken
  • es sollte eine Anzeiger erscheinen, dass der Index aufgebaut wird mit hochzählenden % Zahlen
  • je mehr Dateien, desto länger dauert es, kann bis zu einigen Minuten sein, vorher ist keine Musik verfügbar
  • dann erscheint in der Leiste der Medien (Radio, Spotify, Tunein…) auch USB
  • anklicken und man kann in die Songs navigieren (Titel, Interpret etc)
  • den USB Support bitte nicht vergleichen mit einem Radio in einem Kleinwagen, dort ist man gewöhnt, einen USB Stick oder SD Karte einzuschieben und los geht die Musik… das ist im Tesla im Vergleich extrem rudimentär gelöst!

Das beste Ergebnis in Sachen Geschwindigkeit soll man angeblich mit ext3/4 formatierten Sticks erzielen, die Titel dann in einem Unterordner (also nicht alles im root). FAT32 / NTFS hat aber genauso gut/schlecht funktioniert. Eventuell als letztes Mittel den Center Screen rebooten (reboot tut gut).

Hast du AP2.5 und nutzt zufällig die DashCam-Funktion? Falls dem so ist, kannst du nicht gleichzeitig auf deine Musik zugreifen.

Nicht Dein Ernst?

Ich vermute es liegt am Filesystem des Sticks aber wenn Tesla nicht hinbekommen hat auf einem Stick aufzuzeichnen und simultan davon Musik abzuspielen wäre es mal wieder ein Beispiel für die Unfähigkeit Programmier…

Nicht lustig :slight_smile:

doch lustig :mrgreen:

Mein 128GB Stick funktionierte ab V9 auch nicht mehr. Erst nachdem ich von Windows extFAT auf Linux ext4 formatierte, wird das USB-Icon nach jedem Einstecken eingeblendet:

Der Windows-Kram ist an Lizenzen gebunden. Wegen Kompatibilität sind die Sticks mit FAT formatiert. Wenn dies alte Windows-Kilobyte-Spielzeug bei Tesla nicht funktioniert, dann zahlt Tesla wohlmöglich keine Lizenzgebühren für hunderttausende von Autos. Hat mit Unfähigkeit der Programmierer sicher nichts zu tun. Im Einzelnen muss ein Kunde sich an seinen Nachbarn wenden, der keinen Spielzeug-Computer hat, und für das Ubuntu-Betriebssystem des Tesla Sticks formatieren kann. :slight_smile:

Hi,

und falls man kein Linux-Rechner hat??

https://www.giga.de/downloads/windows-10/tipps/kann-windows-ext4-lesen-und-schreiben-dateisystem-von-linux/

Mit V9 auf meinem S85 AP1 habe ich folgenden Effekt beobachtet:

  1. Zuerst wollte ich TeslaCam testen und habe gleichnamiges Verzeichnis auf USB (FAT32) erstellt. Im Root-Verzeichnis befand sich auch eine MP3. Ergebnis: Keine USB-Schaltfläche erscheint im Display!
  2. Verzeichnis „TeslaCam“ wieder gelöscht und siehe da: USB-Schaltfläche erscheint beim Einstecken des USB-Sticks und MP3-Songs werden angezeigt. (Vor 2. musste ich allerdings das Dateisystem reparieren und es könnte theoretisch auch daran gelegen haben.)

Hi, ob ich AP2.5 habe, kann ich gar nicht sagen … sorry.

Ich habe Autopilot und Herbeirufen und Einparken und so ein Zeugs. Auch die Kameras zwischen in der mittleren Säule und im Emblem in der vorderen Kotflügelseite.

Es kann sein, dass ich den Ordner „TeslaCam“ darauf habe, da ich das auch ausprobieren wollte; es kommt aber kein entsprechendes Symbol und beim Fahren tut sich auch auf dem Stick nichts, die LED bewegt sich nicht - also optisch :wink:

Hallo MichaEl,

Ich dachte die Dashcam Funktion geht erst ab AP 2.5?

Gruß

Kurt

Ja, das habe ich aber erst später bemerkt/erfahren. :wink:

Sonst hätte ich mir auch mal einen Stick vorbereitet, denn auch ich habe AP 1.

Gruß

Kurt

Ganz einfach: Ubuntu auf einen Stick downloaden und vom Stick booten. Aber Vorsicht: Ist wie Umstieg vom Verpenner auf Elektroauto. Wer will danach zurück ins letzte Jahrtausend? Nur Oldtimer, die den Kopf aus der Ölwanne nicht rauskriegen :slight_smile:

Spaß beiseite, kleine Sticks mit nicht mehr als 32GB müssen auch ohne Linux-Dateisystem funktionieren, sonst hat Tesla wirklich was falsch gemacht.