Impressum / Datenschutz Forumsregeln
TFF FORUM TFF E.V. SUPERCHARGE-ME
TFF Forum

Erkenntnisse nach meiner WLAN Obsession

Von Anfang an war das Verhalten meine MS 90D (12/2016, FW 2018.24.1) als WLAN Client für mich irgendwie schwer nachvollziehbar. Dieser Tage habe ich mir mal Zeit genommen das genau anzusehen. Vorab bitte ich um Entschuldigung falls ich da jetzt Dinge redundant berichte die vielleicht schon bekannt waren.

Für die meisten nicht neu dürfte sein, dass die WLAN Empfänger (zumindest die Modelle vor Intel MCU) nicht gerade der Oberhammer sind. Sie bieten bei weitem nicht den Empfang handelsüblicher Handys, beherrschen nur 2,4GHz und maximal 802.11g
Zudem können sie einen verwirren. Bei zu schwachem Empfang verhält sich das Auto zb. ganz gerne so, als wäre das WLAN Kennwort falsch eingegeben. Das hat mich so manchen Nerv gekostet, als ich es schon drei mal hintereinander eingegeben habe.

Nun hab ich einen Accesspoint am Balkon platziert, es herrscht Sichtkontakt. Empfang im MS wird mit 2-3 Balken angezeigt. Danach merkte ich gleich mal, dass (Energiesparen AN, Immer Verbunden AUS) das MS nach nur wenigen Minuten das WLAN verlässt.
Gut, dachte ich mir, ist ja klar, und drehte mal „Immer Verbunden“ auf AN. Danach bemerkte ich dass das MS unwesentlich länger im WLAN bleibt, zumeist etwa 10-15 Minuten. Aber auch dann hat es sich nachvollziehbar immer aus dem WLAN wieder ausgebucht. Das „Immer Verbunden“ wirkt also eher auf LTE in dieser Konfiguration.
Der Neugier halber hab ich dann auch den Energiesparmodus ausgemacht. Und sieh an, erstmals eine Konfiguration in der das MS im WLAN bleibt. Nebenbei beobachte ich, dass es mal so eben 6,5GB runterlädt. Wahrscheinlich klopft da das neue Navi bei mir an der Tür, dass ich noch nicht habe.
Aber: Dieses Verbleiben im WLAN gilt auch in dieser Konfiguration „Energiesparen AUS, Immer Verbunden AN“ nur tagsüber. Nachvollziehbar vertschüsst es sich des Nächtens dann doch wieder aus dem WLAN, um sich dann relativ pünktlich gegen 5:30 wieder im WLAN anzumelden. Das deckt sich auf irgendeine Art mit der Bedienungsanleitung, die ja davon spricht dass des Nächtens sowieso immer ein gewisser Energiesparmodus angeworfen wird.

Meine Schlüsse daraus:

  1. Es gibt anscheinend keinen stabilen Weg derzeit, dass abgestellte MS wirklich ständig im WLAN zu belassen.
  2. Am ehesten noch verbleibt das MS im WLAN wenn Energiesparmodus AUS und Immer Verbunden AN, was aber aufgrund zu hohem Verbrauch für mich nicht in Frage kommt. Und selbst dann scheint es des Nächtens sich nicht für das WLAN zu interessieren. Bringt mich zu Erkenntnis
  3. WLAN ist mit Energiesparmodus verheiratet. Da hilft das ganze „Immer Verbunden“ nichts. Wenn der Energiesparmodus anläuft, ist Schluss mit WLAN und selbst „Immer Verbunden“ zieht nur auf die mobile Verbindung.
  4. Einem Tesla ein WLAN zu gönnen ist nicht so wie man es bei anderen Geräten, Handy etc. gewöhnt ist. Es ist mehr wie einem Tier Futter hinzustellen. Wenn es Lust/Hunger hat, nimmt es was - sonst halt nicht.
  5. Wollte einem Kumpel eine Freude machen, der in der Garage keinen Mobilempfang hat. Dachte ich sorge dafür dass er stabiles WLAN hat, dann kann er trotzdem mit der App zugreifen. Das schmink ich mir nun eher ab bis es neue Erkenntnisse gibt. Weil eben nur mit hohem Vampirverlust und dann immer noch nicht stabil realisierbar.

Ganz verstehen tu ich das alles nicht. Tesla wird bestimmt so manche fette Summen ausgeben für all die Bandbreite die die hundertausenden SIM Karten verbrauchen. Warum da (ähnlich wie Handys) nicht alles getan wird um an einem WLAN zu nuckeln wann immer es geht, ist mir ein Rätsel.

Das Auto verbleibt im WLAN wenn keine Mobilfunkverbindung vorhanden ist.

Ich habe schon immer Energiesparen aus und immer verbunden an. Verliere ca. 2km Rated am Tag. Das (Wasserkraft) ist mir völlig schnuppe.

Ich meine es macht auch einen Unterschied, wenn das Ladekabel angehängt ist (ohne zu laden). Ich bilde mir ein dass er dann konstant im WLAN bleibt. Habe allerdings keinen Mobilempfang in meiner Garage und könnte auch damit zusammenhängen.

Hoffe das ist nicht OT: es gibt durchaus auch WLAN Treiber/Firmware die sich ähnlich verhält, besonders bei schwachen Signal und z.b. nur dann stabil läuft, wenn man das Power Management des WLAN Chips deaktiviert. Je nach dem wie das „Energie sparen“ bei Tesla implementiert ist, könnte sowas auch passieren.

@betatester: danke für deine erfahrung.

Guter Punkt, Danke. Konnte ich in den letzten Tagen mangels eines Platzes an dem kein mobiler Empfang herrscht, nicht testen. Nehme aber an, dass dazu „Immer Verbunden AN“ nötig ist, oder?

Dies ist bei mir an, genau. Ob das WLAN ohne diese Einstellung verbunden bleibt weiss ich nicht.

Hey, danke für deine Erfahrungswerte, sie haben mir einige Fragen beantwortet. Ich bin derzeit auch gerade dabei mit einer WiFi Lösung rum zuexperimentieren.

Stichwort: WPA2 Enterprise in Kombination mit einem Raspberry Pi als Repeater da das Model S dies selbst nicht unterstützt.
Use Case: In meiner Tiefgarage kommt mein WiFi nicht hin aber es gibt dort ein kostenfreies WiFi meines Providers (UPC Wi-Free).

WPA2-Enterprise konnte ich leider nicht testen. Kann grad nicht schauen, hat der Tesla überhaupt die nötigen Felder dafür? Zumindest laut hier WPA2 Enterprise (zugegeben schon ein paar Jahre alt) schaut es hier schlecht aus.

UPC-Wi-Free läßt si ch im Tesla leider nicht verbinden, da nur ein Feld für PW vorhanden ist. Habe das schon reklamiert und steht angeblich in einer Roadmap, dass es geändert werden soll…

Hey,

UPC Wi-Free lässt sich nativ nicht verbinden, dass ist korrekt. Daher auch der Raspberry Pi. Dieser arbeitet momentan bei mir als WiFi Repeater. Daher, er verbindet sich als Client in das UPC Wi-Free Netzwerk da Raspbian mit dem wpa_supplicant auch WPA2 Enterprise Unterstützung mitbringt. Und agiert selbst auch noch als Access Point mit dem ich mein Model S verbinde.

Derzeit habe ich auch das Gefühl das bei meinem Model S der fahrerseitige USB Port powered bleibt auch wenn ich mich von dem Auto entferne wodurch der Raspberry nicht stirbt und die connection hält. Dieses Setup kostet mich Übrigen ca. 8-10 Kilometer pro Nacht wobei ich noch keine Power Optimierungen vorgenommen habe. Zumindest das neue Beta Navi konnte ich dadurch dazu bewegen installiert zu werden :slight_smile:.

Eventuelles Verbesserungspotenzial sehe ich noch darin, dass es unter Umständen möglich ist mein Verbraucher Setup am Raspberry zu reduzieren. Ich habe nämlich derzeit noch einen USB WiFi Dongle dran hängen. Unter Umständen kann ich den noch eliminieren wenn ich zwei virtuelle wlan Schnittstellen einrichte.

Cooles Projekt. Wollte auch schon immer mal einen raspi für den Betrieb im tesla verwursten. Bisher fehlte mir aber die konkrete Projektidee :slight_smile:

Den repeater gleich mit an Board zu haben, könnte vielleicht auch so manchem mit schlechtem Empfang helfen. Interessant wäre, ob vielleicht ein accesspoint wie zb der gute alte linksys wrt 54, hier weniger Strom zieht. Mit dem kann man auch recht gut repeater bauen, zb mittels dd-wrt.

Der neue Raspi 3 den ich verwende ist leider relativ hungrig was Strom betrifft im Vergleich zu den alten Modellen. Da ist sicher was rausholbar. Muss mal schauen ich hab den 54GL sicher noch wo rumliegen :slight_smile:.

LG

Edit: Wobei so schlimm dürfte es doch nicht sein.
raspberrypi.org/help/faqs/#powerReqs

Daher könnte ich mir schon eher vorstellen das die erhöhten Vampire Drain Werte vielleicht durch den fehlenden Sleep Cycle zustanden kommen wenn der USB Output wirklich aufrecht bleibt? Kenn das Auto was das betrifft noch nicht gut genug das ich da eine sinnvolle Aussage treffen kann. Auch ist denk ich am sinnvollsten den Raspi Zero W zu verwenden, verbraucht weniger Strom, kostet nix und ist sehr klein.

Nun - genau der Raspi(-Zero) hat (zumindest als Client konfiguriert) das oben von mir erwähnte Problem.
Tip: Das wlan-interface in den „promiscous mode“ schalten, dann läuft das WLAN über Wochen stabil.

Ich bin immer wieder begeistert, auf was für kreative Ideen die Leute hier im Forum kommen.
+111

Danke für die Info, gut zu wissen. Genau das sind so Probleme die einem Stunden an Zeit in Foren kosten :smiley: .

So, nach all den Themen hab ich mich auch mal etwas mit meinem speziell für die Teslas angebrachten WLAN AP auseinandergesetzt. Fazit daraus ist dass ich nicht schlau aus der Sache werde. Das Model X meiner Frau nutzt das WLAN sporadisch sowohl für DL als auch UL. Wie es aussieht auch das Navi- und Kartenupdate via WLAN bekommen. Im Juli waren 9,2GB DL und 900MN UL beim MX.
Ganz anders mein MS. Nach spätestens 30 Minuten loggt es sich aus und geht auch nicht mehr online. Bis ich wieder zurück nach Hause komme. Ob eingesteckt oder nicht spielt keine Rolle. Interessant ist dass ich mit der MAC Adresse meines MS einen recht hohen UL hab. Teilweise 200MB und mehr pro Tag. Download war im ganzen Juli beim MS knapp 600MB, UL rund 4GB übers WLAN. Also hat sich der Wagen alle Updates mittels LTE-Verbindung gezogen :question:

Warum verhalten sich da die beiden Fahrzeuge so unterschiedlich? Hardwaretechnisch sind sie doch identisch oder?

Keine Ahnung. Ich weiß nur, dass mein Auto (MS) zwar das Navi-Update geladen hat, aber keine neuen Kartensätze.
Wochenlanges rumstehen bei voller WLAN Abdeckung hat daran bisher nichts ändern können.
Das Model S ist eine WLAN-Zicke. just my two cents.

Wurde im Tesla Maps - großes Navi Update 2018 Threat als OT bewertet, vielleicht passt es hier:
Ich habe meinem Tesla einen Gastzugang in der Fritzbox angelegt. Hier mal ein Auszug aus dem Protokoll. Es ist erstaunlich, wie oft an und abgemeldet wird.
Hat da jemand dafür eine Erklärung?